Technical Requirements

Note the following:

  • Ensure that your browser has JavaScript and Cookies enabled.
  • For desktop systems, you must have Adobe Flash Player 10.1 or greater.

Browser Support

Desire2Learn recommends the browsers listed below.  If you encounter any issues accessing d2l.msu.edu using any of the Supported Browser Versions listed in the tables below, please contact the DLS Help Desk.

Desktop Support

Browser Supported Browser Version(s)
Internet Explorer 10, 11
Firefox Latest
Chrome Latest
Safari 5.1, 6.0

Tablet and Mobile Support

Device Operating System Browser Supported Browser Version(s)
Android Android 4 Android Latest
Apple iOS 6, 7, 8 Safari Latest
Microsoft Surface Windows 8 Internet Explorer 11
Blackberry (mobile only) Blackberry 7, 10 Blackberry Latest

COURSE IMPORT COMPATIBILITY

The package formats below can be directly imported into Learning Environment using the browser based import or Bulk Course Create.

  • Blackboard 5.x, 6.x, 7.x, 8.x, 9.x
  • WebCT CE 3.x, CE 4, CE 6.x/8.x (single modules or quizzes only), Vista 4.x/8.x (single modules or quizzes only)
  • IMS Common Cartridge 1.0
  • SCORM 1.2/2004
  • Respondus 2.0, 3.x, 4.x
  • Desire2Learn 8.x, 9.x, 10.x

COURSE CONVERSION COMPATIBILITY

The package formats below can be converted to the Desire2Learn package format with a conversion tool, then imported into Learning Environment using the browser based import or Bulk Course Create. Contact your account manager for more details.

  • CE 6.x/8.x, Vista 4.x/8.x
  • Angel 7.3/7.4
  • Moodle 1.9.x
  • UCompass
  • TLM

The above mentioned products and/or services retain their trademarks and copyrights where applicable.

D2L Brightspace documentation on browser support.